IT技術互動交流平臺

CCNA網絡工程師學習進程(6)vlan相關協議的配置與路由器簡單配置介紹

作者:MenAngel  來源:IT165收集  發布日期:2016-12-16 20:35:46

    前面已經介紹了大部分與vlan技術相關的交換機的協議的配置,更深層次的還有STP協議和以太網端口聚合技術,接著還會簡單介紹一下路由器的基本應用。

    (1)STP(Spanning-tree Protocol)

    問題引入:

    在由交換機構成的局域網絡中通常設計有冗余鏈路和設備。這種設計的目的是防止一個點的失敗導致整個網絡功能的丟失。雖然冗余設計可能消除的單點失敗問題,但也導致了回路的產生,它會帶來如下問題:

1 廣播風暴  
2 同一幀的多份拷貝
3 不穩定的MAC地址表

    1)STP的簡單介紹:

    生成樹協議,又稱擴展樹協定,是一基于OSI網路模型的數據鏈路層(第二層)通訊協定,用作確保一個無回圈的區域網絡環境。通過有選擇性地阻塞網絡冗余鏈路來達到消除網絡二層環路的目的,同時具備鏈路的備份功能。

    STP用于解決局域網的環路問題,它通過在交換機之間實行冗余連接的同時,避免網絡環路的出現,實現網絡的高可靠性。

    STP的配置命令:

  

    當局域網中有多個VLAN并且Trunk鏈路負載過重時,可能需要劃分多個Trunk端口實行負載分擔(均衡),而STP能夠解決由此產生的環路問題。當同一臺交換機的兩個口形成環路時,STP端口權值用來決定哪個口是交換狀態的,哪個口是阻斷狀態的。(STP端口權值實現負載均衡)

    交換機的端口狀態:

關閉(disable): 端口處于管理關閉狀態
阻塞(blocking): 不能轉發用戶數據
監聽(listening): 接口開始啟動
學習(learning): 學習MAC地址, 構建MAC表進程項
轉發(forwarding): 可以轉發用戶數據   

    在PacketTracer模擬器中,交換機默認啟用生成樹協議,橙色的端口表明處在阻塞狀態。

  

    2)STA(Spanning Tree Algorithm)算法:

    IEEE802.1D標準定義了STP的生成樹算法。該算法依賴于BID路徑開銷端口ID參數:

    生成樹協議的算法過程:

  生成樹協議的算法過程可以歸納為三個步驟:選擇根網橋、選擇根端口、選擇指定端口。  
(1)選擇根網橋:在全網中選擇一個根網橋
  比較網橋的BID值,值越小其優先級越高。ID值是由兩部分組成的:交換機的優先級和MAC地址組成的,如果交換機的優先級相同則比較其MAC地址,地址值越小,其就被選舉為根網橋;  
(2)選擇根端口:在每個非根交換機上選擇根端口
  首先,比較根路徑成本,根路徑成本取決于鏈路的帶寬,帶寬越大,路徑成本越低,則選該端口為根端口。其次,如果根路徑成本相同,則要比較所在對端交換機BID值,值越小,則其優先級越高。最后,比較端口的ID值,該值分為兩部分:端口優先級和端口編號,
值小的被選為根端口;
(3)選擇指定端口:在每條鏈路上選擇一個指定端口,根網橋上所有端口都是指定端口  
  首先,比較根路徑成本,其次,比較端口所在網橋的ID值,最后,比較端口的ID值。

    BPDU(Bridge Protocol Data Unit):

    網橋協議數據單元是一種生成樹協議問候數據包,它以可配置的間隔發出,用來在網絡的網橋間進行信息交換。

  

    BID(Bridge ID):

    BID由優先級,發送交換機的Mac地址和擴展系統ID(可選)組成。兩臺交換機的優先級可能相同,但Mac地址不相同,確保了BID的唯一性。而擴展系統ID的目的是為了節約Mac地址。

    不使用擴展系統ID時:(版本老,因此在dynamips中完成):

    BID=優先級(16個字節)+Mac地址(48個字節)

    開啟SW1,并配置交換機,并用show spanning-tree brief 命令查看各vlan下交換機的BID:(在真實機上使用show spanning-tree)

en
vlan database
vlan 10 name vlan10
exit
conf t
host SW1
int f1/1
switchport mode access
switchport access vlan 10
exit

    vlan 10的Mac地址是vlan 1的Mac地址+1。

    使用擴展系統ID:

    BID=優先級(4個字節)+擴展系統ID(12個字節,可以看做vlan ID)+Mac地址(48個字節)。

  

    在左側交換機查看BID:

  

   從Root ID=vlan 1的BID可以看出此交換機是vlan 1的跟交換機,與圖中顯示一致。

   在交換機上創建vlan 10和vlan 20,將左側交換機設置為vlan 10的根交換機,右側交換機設置為vlan 20的根交換機:

   拓展知識:在網絡中如果我想要更改根交換機,可以用下述方法:

1.在沒有擴展系統ID的情況下:
spanning-tree vlan 1 priority 0-65535
2.在有擴展系統ID的情況下:
spanning-tree vlan 1 priority 0-4096

    SW1的配置命令:

en
conf t
host SW1
vlan 10
name vlan10
vlan 20
name vlan20
exit
int f0/3
switchport mode access
switchport access vlan 10
int range f0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end
conf t
spanning-tree vlan 10 priority root
end

    SW2的配置命令:

en
conf t
host SW2
vlan 10
name vlan10
vlan 20
name vlan20
exit
int f0/3
switchport mode access
switchport access vlan 20
int range f0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end
conf t
spanning-tree vlan 20 priority 4096
end

  

    兩個交換機的STP協議配置情況:

  

    路徑開銷:

    端口花費默認和端口的帶寬有關,路徑花費等于根交換機到最終交換機前進方向的端口花費總和。

    端口花費的參考值:

 

    在選取根端口的過程中,修改端口花費:

int f0/1
spanning-tree cost 1-65536

    當STA決定使用一條路徑之后,STA配置交換機的端口角色,端口的角色描述了它與根橋的關系和是否允許轉發流量:

1.RP根端口 :  非根交換機上離根交換機最近的端口(在該端口所在路徑的花費最小),每個非根交換機有且僅有一個。
2.DP指派端口:  每個網段都有一個指派端口,該端口指該網段到跟交換機最近的交換機上的端口
3.非指派端口:  既不是根端口也不是指派端口
4.禁用端口:    被shutdown的端口

    PID=端口優先級+端口號:

    修改端口優先級:

int f0/1
spanning-tree port-priority 0-255

    選取根端口:

1.比較花費,花費小的將成為根派端口;
2.在花費相同的情況下比較發送者的BID;
3.在發送者BID相同的情況下比較發送者的PID;
4.在前面都相同的基礎上比較接收者的PID;

    選取指派端口:

1.比較花費,花費小的成為指派端口;
2.比較BID,BID小的成為指派端口;
3.交換機上PID小的成為指派端口;

    3)配置示例:

    1.3.1生成樹的選舉:

  

    生成樹的選舉過程:

1.比較三臺交換機BID:由于優先級相同,mac地址小的將成為根交換機;
2.對于SW2來說,由于路徑花費相同,發送者的BID也相同,而下面鏈路的發送者的PID(f0/1端口)較小,因此下面的端口為根端口;
3.對于SW3來說,左側端口的路徑花費較小,因此左側端口成為根端口;
4.對于網段三,由于路徑花費相同,SW2的BID小,因此f0/3將成為根端口;

    1.3.2STP協議實現vlan的負載均衡,包括STP端口權值和路徑權值兩種方式:

  

    在SW1和SW2上進行初始vlan 配置:(SW1和SW2配置命令相同)

en
conf t
host SW1
vlan 10
name vlan10
vlan 20
name vlan20
int f0/1
switchport mode access
switchport access vlan 10
int f0/2
switchport mode access
switchport access vlan 20
int range g0/1-2
switchport mode trunk
switchport trunk allowed vlan all
end

    STP端口權值實現vlan的負載均衡:

en
conf t
int g0/1
spanning-tree vlan 1,10 port-priority 16
int g0/2
spanning-tree vlan 20 port-priority 16
end

    STP路徑權值實現vlan的負載的負載均衡:(PacketTracer 不支持,需要在dynamips中實現)

en
conf t
int g0/1
spanning-tree vlan 1,10 cost 38
int g0/2
spanning-tree vlan 20 cost 38
end

    (2)交換機端口聚合:

    端口聚合也叫做以太通道(Ethernet Channel),主要用于交換機之間連接。交換機能把一組物理端口聯合起來,做為一個邏輯的通道,也就是channel-group。

    端口匯聚可以分為手工匯聚、基于IEEE 802.3ad標準的LACP(Link Aggregation Control Protocol,鏈路聚合控制協議)和思科私有的PAgP(Port Aggregation Protocol,端口聚合協議)。

    配置實例:

    在圖中交換機上配置兩條以太網信道,每兩個端口組成一組,有兩個vlan 10,20并且不同vlan優先通過不同的組。

  

    SW1和SW2的配置命令:

conf t
host SW1
vlan 10
exit
vlan 20
exit
interface f0/1
switchport mode access
switchport access vlan 10
interface f0/2
switchport mode access
switchport access vlan 20
exit
int range f0/21-24
switchport mode trunk
switchport trunk allowed vlan all
exit
interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan all 
no shutdown
exit
interface range f0/21-22 
channel-group 1 mode on 
no shutdown
exit
interface port-channel 2
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
exit
interface range f0/23-24
channel-group 2 mode on 
no shutdown
exit

    先在交換機上輸入命令后連接兩臺交換機:

  

    配置STP實現負載均衡:

  SW1和SW2的配置:

en
conf t
interface port-channel 1
spanning-tree vlan 1,10 port-priority 16
exit
interface port-channel 2
spanning-tree vlan 20 port-priority 16
exit
end

  

    配置的最終效果:

  

    在之前做過三層交換機以太網端口聚合相關配置,現在做兩層交換機的配置發現還是有區別的:三層交換機在邏輯端口需要封裝協議:switchport trunk encapsulation dot1q.

    (3)路由器的簡單介紹及簡單配置:

    路由器是因特網的主要節點設備,其主要作用是進行路由計算,將報文從一個網絡轉發到另一個網絡。當路由表中有多個路由信息與目標網絡匹配時,則遵循子網掩碼最長匹配原則(即選擇匹配的最小范圍子網)進行路由。

    路由器常常用于將用戶的局域網連入廣域網,因此很多路由器既有普通的以太網絡端口,又有串行端口(用于連接廣域網設備)。

    端口配置和路由配置是路由器最主要的配置內容。端口配置包括普通以太網絡端口的配置和串行端口的配置。

    路由配置包括靜態路由配置、默認路由配置和動態路由配置

    1)以太網端口的配置:

    配置端口的命令:

  

    2)串行端口的配置:

    路由器串行端口常用的配置命令:

  

    DCE與DTE:

    同步串行端口的同步時鐘信號是由DCE(數據通訊設備,如modem)提供的。默認情況下,路由器串行端口充當DTE。如果查看到該端口是DTE(數據終端設備,如計算機)類型,不必配置同步時鐘參數;如果查看到端口是DCE類型,就必須用命令指定時鐘頻率來配置成DCE端。在串行端口連接中,作為DCE的一端必須要為連接的另一DTE提供時鐘信號。

    HDLC:

    路由器出廠時,默認的串口封裝協議是HDLC(全稱High level Data Link Control,高級數據鏈路控制)。HDLC是面向比特的數據鏈路控制協議,它不依賴于任何一種字符編碼集;數據報文可透明傳輸,用于實現透明傳輸的“0比特插入法”易于硬件實現;全雙工通信,有較高的數據鏈路傳輸效率;所有幀采用CRC檢驗,對信息幀進行順序編號,可防止漏收或重份,傳輸可靠性高;傳輸控制功能與處理功能分離,具有較大靈活性。

    配置實例:

  

    DCE端的配置:

en
conf t
int s0/0/0
ip add 192.168.1.1 255.255.255.0
clock rate 9600
bandwidth 64
no shut

    DTE端的配置:

en
conf t
int s0/0/0
ip add 192.168.1.2 255.255.255.0
bandwidth 64
no shut

  可能出現的錯誤:

  

  解決方法:出現這種現象是由于在DTE端配置了時鐘頻率,用DCE或DTE串口線連接路由設備時一定要注意分清哪個是DCE端,哪個是DTE端。

實驗文檔下載: http://files.cnblogs.com/files/MenAngel/NetBlog6.zip

Tag標簽: 路由器   進程   工程師  
  • 專題推薦

About IT165 - 廣告服務 - 隱私聲明 - 版權申明 - 免責條款 - 網站地圖 - 網友投稿 - 聯系方式
本站內容來自于互聯網,僅供用于網絡技術學習,學習中請遵循相關法律法規
彩票联盟网站 铜梁县| 西盟|